Fehler: xorg - von 1.18 zu 1.20

Mit dem Update von xorg 1.18 zu 1.20 kann es sein, dass das Touchpad plötzlich nicht mehr funktioniert.

Problem

Das liegt daran, dass intern von “devd” auf “udev” umgestellt wurde. Das Ergebnis ist, dass die Kommunikation mit dem entsprechenden Gerät nicht mehr funktioniert.

Lösung

Es muss ein Kernel-Parameter gesetzt werden:

sysctl kern.evdev.rcpt_mask=6

Nachhaltig und permanent sieht das dann so aus:

echo "kern.evdev.rcpt_mask=6" >> /etc/sysctl.conf

Nachdem nun “X” neu gestartet wurde, funktioniert das Touchpad wieder.